Uploaded image for project: 'Doctrine PHPCR'
  1. Doctrine PHPCR
  2. PHPCR-87

the document manager did not return a result for findBy(array('id' => 'some/id')) but does for find('some/id')

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Invalid
    • Labels:
      None

      Activity

      rmsint Roel Sint created issue -
      dbu David Buchmann added a comment -

      the id is kind of a meta information of the document, not a property. so i am unsure if this can work, as the findBy is querying on the phpcr fields. we can not search on the odm mapped fields, as we do not know which document to search, and different documents could even map differently.

      so i am not sure if we can solve this issue at all, except improve the documentation of what findBy is actually using.

      or am i missing something, lukas?

      dbu David Buchmann added a comment -

      findBy filters on properties. the id is the path of the node, not a property. this is thus not a bug.

      i converted a lot of doc from the orm to have the right place where we should explain this, adding a warning about this case: https://github.com/doctrine/phpcr-odm-documentation/pull/24

      dbu David Buchmann made changes -
      Field Original Value New Value
      Status Open [ 1 ] Closed [ 6 ]
      Resolution Invalid [ 6 ]

      This list may be incomplete, as errors occurred whilst retrieving source from linked applications:

      • Request to http://www.doctrine-project.org/fisheye/ failed: Error in remote call to 'FishEye 0 (http://www.doctrine-project.org/fisheye/)' (http://www.doctrine-project.org/fisheye) [AbstractRestCommand{path='/rest-service-fe/search-v1/crossRepositoryQuery', params={expand=changesets[0:20].revisions[0:29],reviews, query=PHPCR-87}, methodType=GET}] : Received status code 503 (Service Temporarily Unavailable)

        People

        • Assignee:
          lsmith Lukas Kahwe
          Reporter:
          rmsint Roel Sint
        • Votes:
          0 Vote for this issue
          Watchers:
          2 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved: