Doctrine PHPCR
  1. Doctrine PHPCR
  2. PHPCR-68

Versionable Item completely loses references

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Labels:
      None

      Description

      I have a post that has a reference to a subcategory

      When i made my post versionable="full", the current and old versions of post lost this reference.

      So when i call $post->subcategory i get back a Generic ODM document instead of a Subcategory Document

      I know that relationships are not versionable, but relationships should at least still exist.

      The workaround is to get the parent path and make a JCR-SQL2 query to fetch the subcategory document.

        Activity

        Freddy H. created issue -
        David Buchmann added a comment -

        note that this could also be a problem in jackalope. we seem to have issues with the frozenNode thing (either in the implementation or in the correct understanding) https://github.com/jackalope/jackalope-jackrabbit/issues/19

        Lukas Kahwe added a comment -

        please reopen once you have a reproduceable test case, thx

        Lukas Kahwe made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]

        This list may be incomplete, as errors occurred whilst retrieving source from linked applications:

        • Request to http://www.doctrine-project.org/fisheye/ failed: Error in remote call to 'FishEye 0 (http://www.doctrine-project.org/fisheye/)' (http://www.doctrine-project.org/fisheye) [AbstractRestCommand{path='/rest-service-fe/search-v1/crossRepositoryQuery', params={query=PHPCR-68, expand=changesets[0:20].revisions[0:29],reviews}, methodType=GET}] : Received status code 503 (Service Temporarily Unavailable)

          People

          • Assignee:
            Lukas Kahwe
            Reporter:
            Freddy H.
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: